Author: Halfvares Mats, Teknikhuset AB.

Published: 2007-02-13

Applies to:
  • Content Studio ver. 4.x

Type: How to


Symptoms

Sometimes a document fails to build in Site Content Manager. In Content Studio 4 this will unfortunately cause the process to stop and the site file cannot be fully synchronized.

Cause

The most common reason is a corrupt document or a document that contains a document with a corrupt AS-component that cannot be parsed successfully. Also this can occur with some documents that is in the recycling bin.

Resolution

You need to find the corrupt document but since Site Content Manager only shows the last document successfully built. There are no built in functionality to find this document since the tool only displays the file names. However the good news is that documents are built in the order of its internal document id which means that you only have to find the document that succeeds the document with the specified filename.

In the result pane of Site Content Manager you should take a note of a the file name (ex. 27279A13-194D-4A8F-8685-830C686071EB.ASP).

The following TSQL script lists the 5 documents that follows after the last successful document.

SELECT TOP 5 
ElementID, 
ElementName, 
[FileName] 
FROM dbo.tbl_Elements 
WHERE ElementID > (SELECT ElementID FROM dbo.tbl_Elements WHERE [FileName] LIKE '%FILENAME') 
            

Replace the FILENAME word with the file name recorded earlier and execute the script in SQL Management Studio / Enterprise Manager or the Osql utility. Be careful to execute it against the database representing the site with the problem.

A list of documents appears. Find the affected document in Content Studio. If it is in the recycling bin, delete it. If it is an ordinary document open it and approve it. You can also open all of the AS-components on the page to see if they are healthy before approving the document. If the document is an uploaded file upload it again or turn off Image processing on its category.

Run Site Content Manager again.

Status

This is a problem with Site Content Manager that does not allow the process to continue after an error on a single document. This problem has been fixed with Content Studio version 5.